0

Running EE 5.3.2

Unfortunately I have to address this issue again and I am hoping for some sound advice that will help resolve this problem forever.

We post a weekly blog on Hobblecreek. They are lengthy posts with 12-15 photos. It takes hours to craft the entry and almost every time ExpressionEngine times out and I lose some or all of the work. In the middle of an active session the login screen suddenly pops up without warning and I have to log back in. I save as I go, but this is bothersome because saving requires that you go back in and find your spot in the entry. However today, despite saving multiple times, the entire entry was lost. Completely vanished.

This error comes up as well:

enter image description here

In Security & Privacy settings I have it set as follows:

settings

This has happened so frequently that I would gladly walk away from Expression Engine if there was a better solution out there. I have been building EE sites for 12 years and this is the worst experience I have ever had with EE.

What can I do to prevent ExpressionEngine from timing out like that?

1

Changing CP session type to SessionID only can help.

| improve this answer | |
  • I changed it to Session ID only. How long does a session last? Is there a way to set the time for a session? – forrest Jul 20 at 15:04
  • So far this appears to be working. This is the first time in several months that the control panel did not boot me out while working on an entry. Thank you. – forrest Jul 23 at 17:54
  • I don't know where the session timeout setting is, probably in a core file somewhere, but glad it's working! – Bluedreamer Jul 24 at 18:33
1

Rather than fix the timeout, perhaps it would be easier to simply save your work-in-progress as a draft periodically during the creation of the blog post? Then if you are timed out you can at least go back to the most recently saved draft?

To do this you will need to create a new status "draft" - which you can do in the channel settings for the channel you are using. Then in the default screen layout, the Status of the entry can be set by clicking on the "options" tab for an entry.

I think channel:entries defaults to only showing 'open' entries if status is not specified, but to be sure the draft is not published before it is ready you might want to add the parameter status='open' to your blog channel:entries tag.

When you are ready to 'publish' your blog post, change the status to Open and save it.

HTH

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.