0

Sorry for another potentially simple question. I've successfully managed to upgrade to EE 5.3.2, and everything seems to be working 99% correctly. Only two issues needed to be corrected. The first was that I needed to update the directory of emoticons/emojis in my settings. The second, however, seems to be that the image upload modal in my Create New Entry page will not work.

Empty Modal

This is what I'm getting when I click on the icon to upload an image into any text field where images are permitted/intended.

There is a JavaScript error that I'm not sure is at fault or not. It occurs on index.php line 722 for me. The error is:

Unfortunately, it's not the most clear error, which is one of the reasons I don't know how to search for info on it. I have no clue if this is related to the empty modal or not, but it seems like something I should look into. The specific error in Chrome's console is: GET http://www.url.com/system/index.php?S=a4a3cfc8698b1994e6b6b14b73300c66&D=cp&C=javascript&M=combo_load&file=cp/global_end,cp/files/picker,fields/textarea/cp,cp/date_picker&v=1600791531 net::ERR_ABORTED 406 (Not Acceptable)

I wish I had a more clear question to ask. If anyone can help me out, please do. Thanks!

1

It looks like something may be tripping up a mod_security rule on the server, that can happen from time to time if the rules are too strict.

How to check:

  1. Make the error happen using the field, make a note of the time
  2. Check server logs to see if any mod_sec rules have been triggered
  3. Disable any triggered rules
  4. Test the field again, is mod_sec was the problem the field should work as expected
| improve this answer | |
  • Sorry for the slow response. I don't currently have any error logs via the Control Panel dashboard, and looking through my server logs shows no error of the sort. Is there a specific error log I should be looking at/for? Is there somewhere I can see the mod_security rules specifically? – ccesarano Oct 7 at 15:47
  • If you haven't got access to all server logs you'd need to ask you host to trace what mod_sec rules may be being triggered. – Bluedreamer Oct 25 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.