0

My hosting company upgraded to PHP 7 recently which rendered an old site running EE2 inaccessible on the front end and admin sides. I completed an upgrade from EE2 to EE3.5.17 after reading that EE3 was compatible with PHP 7 hoping this would be an easy fix. The upgrade went well through the installation until I got the following error and can't access the admin side.

Unable to load the following extension file: ext.dry_accessible_captcha.php

I did some research and read where all add-ons not compatible with EE3 needed to be removed prior to completing the upgrade. However, in this case, I was not able to do this since I did not have access after my hosting company made the PHP update. Any ideas on a workaround to get me up and running?

0

You have a few options.

If it's just extensions, you can use this configuration override to disable all extensions:

$config['allow_extensions'] = 'n';

Add that line to the end of your config.php file. That might allow you access to your Control Panel to move forward with removing add-ons.

Another option is to (backup these tables first) truncate your exp_extensions table and remove any non-first party rows from your exp_modules table. Your exp_actions table will be left with some orphaned rows from the modules you are ditching, likely, so pay attention to that.

But disabling extensions should get you back in to your Control Panel at least.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.