The docs for Freeform say the return_url should look like return_url="{path='my/template/submission/SUBMISSION_ID'}" but when I do that I end up on a page with URL = /my/template/submission/SUBMISSION_ID, i.e. SUBMISSION_ID doesn't get replaced with an actual ID.

I've also tried installing the demo templates which have the same and submitted the form, and get the same result.

What am I missing?

1 Answer 1


Are you storing submission data for the form? Please make sure to have the Store Submitted Data setting checked off inside the Settings tab in the form builder. Otherwise, this feature will not work correctly.

If that isn't the issue here, please submit a support ticket with more details and we can help you troubleshoot there. :)

  • Does checked off mean that it should be checked (i.e. on), or not checked? It's checked on and submissions have been stored in the database.
    – Tyssen
    Jan 13, 2021 at 9:39
  • Sorry, by "checked off" I meant "checked" / checked on. You'll probably need to send us a support ticket with more information :)
    – Solspace
    Jan 13, 2021 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.