0

After updating from version 2 to version 6, I get the following error when I want to edit an entry. Can anyone help me out?

Notice
Undefined index: extension

ee/legacy/libraries/Extensions.php, line 145

    Severity: E_NOTICE



Error
Unable to load the following extension file:
ext.rte.php
1

For the time being, the best solution would be manually remove record from exp_extensions DB table.

And of course, report a bug.

0

The error is caused by EE6 trying to load ext.rte.php which appears to be a built in module in EE2 used to provide access to the RTE preferences in the CP. The module continued to be used through until EE5, but was removed in EE6 (which is why EE6 cannot find it...).

For the error to occur, it seems likely that something has gone awry during your update. If you have the backup files available I would try re-running the migration; if the error occurs again on the second run through, it might be that something in your EE setup is confusing the updater, or a specific update problem for the EE6 updater. If that happens, probably the best course of action is to file a bug / issue within the EE github - as it might be that a fix is needed to the updater code.

If you don't want to go down that route, the alternative would be to do your update in stages - there was a big change in EE between EE2 and EE3 - so start by doing just that jump, check that the migration went OK and if that works then go for the one-click update route through to EE6.

If you need copies of EE3-4-5 you can get them from the releases area on the EE github.

HTH.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.