0

My university cannot allow for H1 tags in the RTE as we have to hold that important ADA tag for the page titles. There may have been a config somewhere in the affected EE6 install (developers tied up with priorities) b/c the solution was to keep an h1-h3 dropdown but render as follows: h1 as h2, h3 as h4 and h4 as h6. I only have 3 options. I'd like to at least a 4th option (h4 which would then render as h5). Where in the system can i add this?

0

There is no proper way to add this setting. But we have to add some extra code to the ckeditor.js file.

You have to add the code as per the below screenshot. enter image description here

Updated code for that part:

 constructor(t) {
            super(t), t.config.define("heading", {
                options: [{
                    model: "paragraph",
                    title: "Paragraph",
                    class: "ck-heading_paragraph"
                }, {
                    model: "heading1",
                    view: "h2",
                    title: "Heading 1",
                    class: "ck-heading_heading1"
                }, {
                    model: "heading2",
                    view: "h3",
                    title: "Heading 2",
                    class: "ck-heading_heading2"
                }, {
                    model: "heading3",
                    view: "h4",
                    title: "Heading 3",
                    class: "ck-heading_heading3"
                }, {
                    model: "heading4",
                    view: "h5",
                    title: "Heading 4",
                    class: "ck-heading_heading4"
                }]
            })
        }

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.