0

We're using open tags in layouts to dynamically drive Twitter and FB previews.

{layout:set name="og-tags"}
<meta name="description" content="{intro}" />
<meta name="keywords" content="Remote Learning, Online Learning, Faculty Online Guidance, UMass Boston" />
<meta name="twitter:card" content="{banner}{url}{/banner}" />
<meta name="twitter:title" content="{title}" />
<meta name="twitter:site" content="@umbelearning" />
<meta property="og:url" content="{url_title_path}" />
<meta property="og:title" content="{title}" />
<meta property="og:description" content="{intro}" />
<meta property="og:image" content="{banner}{url}{/banner}" />

{/layout:set}

The previews not working on twitter (fine on FB).enter image description here Page source shows tags rendering image but not displaying. ex) https://teachonline.umb.edu/course-design, https://teachonline.umb.edu/assessment etc. And only homepage even shows the card preview. [see attached]

1

Solution: This syntax is incorrect: <meta name="twitter:card" content="{banner}{url}{/banner}"> It should be <meta name="twitter:card" content="summary_large_image" /> Used this debugger site -> https://cards-dev.twitter.com/validator

0

Please remove the "/" slash before the ending meta tag.

Check below code.

...
<meta name="twitter:card" content="{banner}{url}{/banner}">
<meta name="twitter:title" content="{title}">
<meta name="twitter:site" content="@umbelearning">
...
1
  • H @zealousWeb I tried that but it doesn't resolve the preview issue, – lberelson May 7 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.