0

after upgrading from 5.4.2 to 6.0.6 in the CP I get the error

Warning Attempt to read property "group_name" on null ee/ExpressionEngine/Model/Template/Template.php, line 118

Severity: E_WARNING

What does that mean and how could it be fixed? Main parts of the website (frontend) seem to run ok.

Thanks in advance for any advice!!!

EDIT: I found that the error appears when I edit a template. Editing the template via CP or via FTP-file works, also creating and deleting template groups. What could this be?

7
  • 1
    Don't believe I've seen this one come up before. Gut reaction is that I would go into the template manager and save a template (which should cause the templates to sync in the system)
    – Tom Jaeger
    Commented Jun 28, 2021 at 11:32
  • 1
    Can you check the "group_name" column of the database table 'exp_template_groups'? Is there any empty value?
    – ZealousWeb
    Commented Jun 30, 2021 at 7:27
  • @TomJaeger Thanks for your help - somehow the error has vanished. I edited a template-file via FTP, I am not sure if this was the action that fixed it. Perhaps this indeed did a sync, as you have suggested.
    – BNetz
    Commented Jul 1, 2021 at 17:29
  • 1
    @ZealousWeb Thanks for this suggestion - there is no empty field in this table. But as you might see in my last comment the error vanished without obvious reason (at least for me).
    – BNetz
    Commented Jul 1, 2021 at 17:30
  • @TomJaeger Now I found that the error comes up when I edit a template. Saving one changes nothing … Any other idea?
    – BNetz
    Commented Jul 8, 2021 at 19:46

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.