0

When using a Relationship field with a Fluid field type the current_field_name variable can be printed out for debugging just fine, but IF conditionals don't work when using current_field_name.

{exp:channel:entries channel="testfluid" dynamic="no" show_future_entries="yes" limit="1"}
    {testfluid}
    debug print out {testfluid:current_field_name}
    {if testfluid:current_field_name=="my_relationship_field_name_as_printed_out_fine_one_line_before"}
        #anything here never gets processed
        {content}
            {content:title}
        {/content}
    {/if}
    {/testfluid}
{/exp:channel:entries}

Also tried wrapping testfluid:current_field_name in braces, no change.

Just to be clear: if I remove the IF condition the relationship field is processed just fine, it's just the IF conditional not working. That wouldn't be an issue if one was only using a Fluid with one field, but obviously causes trouble with multiple different field types within a fluid.

Using latest EE version (6.2.4).

3
  • Have you noted the conditional isn't closed?
    – Sobral
    Feb 8, 2022 at 21:08
  • Ooops, just a typo, thanks, fixed (original code does have the closing IF) Feb 9, 2022 at 22:05
  • Have you tried on a clean template? I had issues before with tags opened on other parts of the template that I forgot about.
    – Sobral
    Feb 17, 2022 at 0:13

1 Answer 1

0

You could try

 {if '{testfluid:current_field_name}' == '{my_relationship_field_name_as_printed_out_fine_one_line_before}'}
1
  • That's what I referred to by "Also tried wrapping testfluid:current_field_name in braces, no change." Feb 7, 2022 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.