0

Firstly, I was using the hosts file to point the server/hosting ip to a domain.

I went into Files, and tried creating an Upload Directory. All I did was give it a name and 'Saved'. An error appeared stating I had to select something from the 'Adapter' field. I selected 'Local', clicked saved and instantly received the 500 Internal Server Error page. I cannot view any part of the frontend or EE backend.

'..a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.'

Trying to access any file with a php extension gives the error.

An error that appears in cPanel 'Errors': 'client denied by server configuration: /home/username/public_html/.user.ini'

Tried clearing .htaccess, no change. Am using EE 7.2.10

ANY HELP on how to get things back would be extremely appreciated!

0

4 Answers 4

1

The quickest way to get back up and running might be to go through cPanel and PHPMyAdmin to open your database. And then navigate to the exp_upload_prefs table and delete the row for the Upload Directory that you just created.

However, this won't tell you what the problem was. I would also recommend making sure you have debugging enabled so that you might see a more helpful message. On a non-production site you can edit your admin.php and index.php files and change $debug = 0; to $debug = 1;

It's possible there were permission problems with the directory's location but getting a more descriptive error message would help pinpoint the problem.

1
  • THANKS very much for the quick response. I deleted the row In the exp_upload_prefs table. I turned on debug to both those files but still seeing the 500 error. Cannot access anything at all!?
    – ZEDG
    Mar 8, 2023 at 12:38
0

I would contact your host and ask for your IP address to be allow listed.... I've run into this a few times when my IP address has gotten blocked for some reason.

The 500 error could likely be from the server and NOT ExpressionEngine.

1
0

Which php version are u using? Try 7.4 in case...

1
  • Am on version 7.4.
    – ZEDG
    Mar 9, 2023 at 2:18
0

Host/server support had to Reset PHP for the domain. (Didn't know that was even a thing.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.