1

I have an odd problem: Entries wth german umlauts (ä ö ü), in the the title oder anywhere else, will not save. Instead the field will clear and the page will reload. There is no JS validation going on.

My problem is pretty much the same as described here: http://ellislab.com/forums/viewthread/196640/#925586 though i can not fix it just by using php 5.2.x (I run 5.2.14)

Extension wise i run navee, wygwam, matrix and multi language support by biber ltd.

Umlauts in the wygwam-field are possible if I use the option to encode them to entities.

As for the database this strikes me a bit odd... but I am not the server-admin and can not test around easily.

collation_connection:   utf8_general_ci
collation_database: utf8_unicode_ci
collation_server:   latin1_swedish_ci

Thanks in advance, guys.

  • 1
    What version of ExpressionEngine are you using? Also, is this a local install or on a production server. ExpressionEngine itself is generally fine with umlauts, so I'm wondering if its your server configuration. I could be wrong, but shouldn't collation_server also be utf8_general_ci instead of latin1_swedish_ci or you'll get encoding issues. – nonprofit_tech Jan 14 '13 at 19:56
  • I am on ExpressionEngine version 2.5.3 on a production server. – portnull Jan 15 '13 at 10:11
  • do they occur if you type the characters too? or only when pasting? i've had some success with caleydon.com/en/project/cm-nice-url what is you db encoding set to? – Jelle Dijkstra Jan 15 '13 at 18:21
2

Hmm, odd one, i would have to say that the collation_server being latin 1 would be at fault. Collation specifically is responsible for comparing and sorting in mysql. So, i'm guessing in the saving of the entry, it's trying to compare data, that is: one being utf-8 once it's in the db, and one that is latin1 before it gets to the db. This would cause a fatal mysql error and prevent any further inserts or whatever. You're going to have to get that server collation changed i would say.

| improve this answer | |
  • 1
    I'd recommend changing all to utf8_unicode_ci: stackoverflow.com/questions/766809/… – Mark Croxton Jan 16 '13 at 13:23
  • Good point, i hadn't even noticed the first one wasn't utf8_unicode! – JohnWBaxter Jan 16 '13 at 16:31
  • i got this to work in the end. the culprit wasn't the database at all but a bad installed / configured iconv on the server. – portnull Feb 8 '13 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.