6

I am using simple search tag in EE, and for some reason, the search results don't show pages in which the search term is in Matrix fields. I do have those fields set to searchable in Matrix so I am very confused.

Here is my EE template form structure:

{exp:search:simple_form channel="disability_topics2" search_in="everywhere" result_page="/search" status="not closed" where="all" show_expired="yes" show_future_entries="yes"} Search Site:
{/exp:search:simple_form}

What can I do?

In the entry publish page I have a Wygwam field for the "main page content" and then a Matrix field with two text areas (which are set to searchable). However, when I do a search, it will pull up entries with search terms in the "main page content" field, but not the Matrix field.

I hope that makes sense.

Thanks!

Michael

  • 1
    Is the matrix field itself set to searchable? (Not the columns) – Jason Varga Jan 14 '13 at 20:59
  • I'm such a bonehead. It was not. Now it is and it works. Thanks! Sorry about that. – Michael Chase Jan 14 '13 at 21:02
8

Make sure the Matrix field itself is set to searchable as well as the appropriate Matrix columns (see screenshot).

If your column wasn’t set to Searchable already, you’ll need to re-save your entries for the change to take effect.

Matrix Settings

| improve this answer | |
  • Jason can you expand your answer with more detail/screenshots about how to check each of these settings? – Anna_MediaGirl Jan 14 '13 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.