3

How I would go about adding the jquery spellcheck plugin to WYGWAM?

3
  • Probably start by following the "Usage" instructions on the page you linked to. What have you tried so far? Jan 15 '13 at 21:04
  • I started following those instructions but got lost on step 4. Don't wanna just hack WYGWAM. I'd rather do it properly (i.e. the way Pixel & Tonic intended, whatever that may be).
    – vibe9
    Jan 15 '13 at 23:57
  • I doubt you will be able to do it without hacking Wygwam, at least to some extent. At the very least you would need to create a new ExpressionEngine add-on and write some code to integrate it with Wygwam. I don't know enough about it to point you in the right direction though, sorry. Jan 16 '13 at 4:10
15

Here’s an extension that should do the trick for you: Wygwam jQuery Spellchecker

Enjoy!

5
  • Awesome - now I'm stoked. Thanks Brandon! I'll install this hopefully tonight and let you know if I run into anything.
    – vibe9
    Jan 16 '13 at 23:06
  • Nice one Brandon! Jan 17 '13 at 5:20
  • Hey Brandon, so I've installed the extension and have encountered a bit of a snag. In the WYGWAM editor configuration the new spell checker buttons appeared, and I added them to the editors I have setup. However, on the publish/edit page the WYGWAM field now disappears. BTW, I followed all of the steps in the docs and double checked the folder path; I also tried with "defer CKEditor initialization" on and off to no avail.
    – vibe9
    Jan 17 '13 at 18:37
  • Correction - I did not actually see the spell checker icons at all. I mistakenly thought the original spell check icons were the jquery ones. So backup a step - I'm not seeing the icons in the wygwam config editor. Should they appear automatically in the icon bar? (I am running WYGWAM 2.6.3 and EE 2.5.3)
    – vibe9
    Jan 17 '13 at 18:44
  • page not found...
    – P..
    May 18 '14 at 21:38
0

Check to see if your host has modsecurity enabled. Modsecurity might block the extension from loading giving you that 404.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.