I have updated Assets from version 1.2.2 to 2.0 following the steps on the P&T website.

After going to 'Add-Ons -> Modules', selecting 'Run Module Updates' and confirming 'Update' on the Assets warning page, I received various PHP errors (which I stupidly did not copy). I was able to re-load that page and view the updated UI for Assets.

I no longer see any of the files and images that were present in Assets 1.2.2 in the File Manager. Images on the front end are also now missing. Viewing the database, it looks like everything ing the exp_assets_files table is gone.

I have also run 'Updated Indexes' for both of my directories handled via Assets and cleared my browser cache.

I am attempting the update locally via a MAMP install running PHP 5.3.14 and do have a db backup.

Any ideas?

  • Follow up, I rolled back to my commit before trying to update to 2.0 and also restored the db. Same error messages which I have captured this time: A PHP Error was encountered Severity: Notice Message: Undefined index: 1:client-logos Filename: assets/upd.assets.php Line Number: 709 This same error repeats for different directories I had created in Assets 1.2.2.
    – Chad Clark
    Jan 15, 2013 at 22:08
  • What does your Assets folder structure look like?
    – Brad Bell
    Jan 15, 2013 at 22:56
  • 1
    If you want to go ahead and send your db backup over to support@pixelandtonic.com, I can look into this and see what's going on.
    – Brad Bell
    Jan 16, 2013 at 0:49
  • Hi Brad, I have sent you the db backup. Thanks for looking into this. The Assets folder structure is: /assets/uploads/images/ /assets/uploads/files/ Various subfolders were created via Assets inside each of these directories.
    – Chad Clark
    Jan 16, 2013 at 15:41
  • Please direct bug reports directly to developers - thanks! Jan 19, 2013 at 23:07

3 Answers 3


This is because your Upload Filedirs have relative paths in Server Path field - this was somehow forgotten in the whole process. This will be fixed in the upcoming release, but, in the meantime, you can just set it to an absolute path and that should work for you.

  • Andris, can you be a bit more specific? Are you referring to setting File Upload paths in the config file?
    – Chad Clark
    Jan 16, 2013 at 15:43
  • Chad, I mean in EE's File Upload preferences, sorry for the confusion. Jan 16, 2013 at 18:12
  • The config settings actually apply directly to File Upload settings, so by setting 'server_path' => $config['server_path']."assets/uploads/images/", and 'url' => $config['site_url']."/assets/uploads/images/", etc., it does apply the full paths in 'File Uploads'.
    – Chad Clark
    Jan 16, 2013 at 18:37

I am currently running EE 2.5.4 and I just upgraded to Assets 2. The upgrade went smoothly and is operational.

I can view my files in both thumbnails modes (small and big) but I have an error showing up when I try to view files in a list.

    load->view('listview/files'); ?>        

Screenshot: http://i.imgur.com/3nKZW.png?1

  • Release Assets 2.0.2 today which should fix this for you.
    – Brad Bell
    Jan 18, 2013 at 3:07
  • This isn't really appropriate as an answer. Next time I recommend you use the add comment link.
    – UltraBob
    Jan 21, 2013 at 8:38

To follow up, Brad from P&T was able to send me a build that updated successfully. Thanks to him and P&T for doing this so quickly!

Not the answer you're looking for? Browse other questions tagged or ask your own question.