I was doing an update from 2.4 to 2.5.5 using Updater, it seemed to install EE but when it got to updating the modules it gave an error about the Referrer module and seemed to stop. It looks like the EE update worked fine, but if i try access the Referrer module it get this error

A PHP Error was encountered

Severity: Notice

Message: Undefined property: Addons_modules::$dbforge

Filename: referrer/upd.referrer.php

Line Number: 156

Fatal error: Call to a member function modify_column() on a non-object in /system/expressionengine/modules/referrer/upd.referrer.php on line 156

Any ideas what's up?

3 Answers 3


Try this... Open /system/expressionengine/modules/referrer/upd.referrer.php, add a new line just after line 141, then add the following to that new line:


Save to the server and try to access the Referrer module page.

  • 1
    Hi, thanks for you help, I didn't get a chance to test this code as the problem seemed to have sorted itself. I've been doing a fair bit of playing around on the site and I clicked the "update modules" button that sits in the modules section instead of visiting the referrer page directly and I think that managed to run the update without error. Not sure why the update failed on EE upgrade, or when visiting the module page though. I've been changing some of the other addons today too so maybe something else i did also influenced it.
    – Joobs
    Commented Jan 16, 2013 at 18:45
  • Great! Can you post your solution of updating modules as an answer and accept your answer as correct by clicking on the checkmark to the left of the answer... There might be a time delay before you can select the answer as correct.
    – Anna_MediaGirl
    Commented Jan 16, 2013 at 18:49

Clicking the "update modules" button on the module admin area seemed to run the update. Although never got to the bottom as to why the upgrade failed on EE update or when visiting the referrer module page.


I'd suggest reuploading the Referrer module's files as a first step. It's possible something got corrupted on the upload.

  • Files look ok and i've re-uploaded to be sure. Still the same problem. Seems to be something wrong with the update script, I would try to de/re-install the module but I would like to keep that refer data in place.
    – Joobs
    Commented Jan 16, 2013 at 0:24
  • You could backup that specific table in the database and then uninstall/reinstall... then restore the DB table. I don't know offhand where in the DB that data is stored.
    – Anna_MediaGirl
    Commented Jan 16, 2013 at 1:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.