4

I have the most baffling problem. I have a live server where working in the EE backend is very slow due to a javascript and a css request called via http://domain.com/admin.php?S=0&D=cp&C=javascript&M=load&file=ext_scripts and http://domain.com/admin.php?S=0&D=cp&C=css&M=cp_global_ext respectively. Each takes 10 seconds to load.

The baffling part is that it only happens on one server (the production server). I have the exact sites mirrored on a staging server as well as my laptop and neither exhibit the behavior.

What could cause this? I am at wits end on this one and any help would be a godsend.

Thanks!

3

Because this isn't happening in your local development environment, I would guess it's not EE related but instead is caused by something on the server or is DNS related.

But here are some things to try/check:

  • Log out of EE, clear all cookies and cache, then log back in
  • Disable extensions temporarily by adding this to your config.php file $conf['allow_extensions'] = "n";
  • Disable “New version Auto-check” in your Control Panel under Admin > General Configuration
  • Uninstall the "ExpressionEngine Info" accessory under Addons > Accessories
  • PHP error logs
1
  • 1
    Hey Anna, I tried all of them with no luck. It appears any call made to the control panel for loading javascripts, etc. (basically when the GET variable D=cp is present) is slow. At this point, I too think it's the hosting but they won't claim responsibility. While they acknowledge the problem but they say it's nginx or EE and both are unsupported. Thank you so much for your help! Jan 17 '13 at 13:54
3

I have just spent many hours trying to resolve the very same issue, however, I was relunctant to upgrade PHP.

On my production server, JavaScript was taking 5 seconds to load slowing down the responsiveness of every page within the control panel. However, the issue did not occur on my local (MAMP) server.

I went through a process of disabling all the Accessories, checking PHP version etc. but nothing worked.

I finally got a clue from this post on EE’s forum which mentioned disabling Generate HTTP Headers.

This worked for me.

In fact, having read the documentation it is clear that this can cause problems, 'Sending explicit headers is generally considered to be a good practice, although in some cases it can cause some problems'.

I hope this helps anyone else who may come across this issue and stumble on this post.

1

Riddle solved but I don't know why.

I went ahead and upgraded php to 5.4.11 from php 5.3.9 and the behavior is gone.

Mea culpa, it was not the hosting. I don't know why things were bad under php 5.3.9 but they were for whatever reason.

1
  • 1
    Glad you got this sorted!
    – Anna_MediaGirl
    Jan 17 '13 at 17:14
0

If you have devot:ee monitor accessory installed; uninstall it. It's deprecated, and will cause isses with slow CP loading time (1 minute loading CP Home).

0

I had the very same problem attempting to load the ext_scripts entry as well. It would work on developer's machines but not on the actual test / production servers. In our situation it turned out to be because the actual servers were in a DMZ zone where the firewalls did not permit outbound HTTP / HTTPS traffic and one EE plugin (Publisher) was attempting a phone home HTTPS request to check to see if updates were available. Worked around this by putting a /etc/hosts entry in place for the requested domain (boldminded.com) and pointing it to 127.0.0.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.