4

I just upgraded to Assets 2.0 on EE 2.5.3. Installation went smoothly.

However my upload locations aren't acting correctly from within Assets.

My folder structure looks like this:

system
html
  assets
  docs
  images
  minified
  themes

html/assets and html/docs are both set up as upload directories in EE.

I'm using Master Config to set them. But even looking through the CP I can see they are correct. The server path is correct and the Upload Directory URL is absolute, not relative.

But the Assets file browser shows the folder structure of both directories as if they were pointed at the html folder. (see screenshot)

Assets screenshot

Thanks

  • Hey Jason, have you updated your indexes yet? – Brandon Kelly Jan 16 '13 at 21:52
  • Yeah, it indexed everything in those folders shown in the screenshots. – Jason Varga Jan 16 '13 at 21:56
  • 1
    Can you try setting the server paths directly, bypassing Master Config, and then try updating indexes again, and see if they show up correctly? – Brandon Kelly Jan 16 '13 at 22:09
  • Still shows the wrong folders. – Jason Varga Jan 16 '13 at 22:24
  • Can you try updating to Assets 2.0.1? If it’s still borked, it might be easier if we could go in and see what’s going on for ourselves. Is this on a public server? If so you can email super admin and FTP credentials to support@pixelandtonic.com. – Brandon Kelly Jan 16 '13 at 22:34
5

Okay here is what I did to get this working correctly. This by no means solves the initial problem but it does get you up and running again.

I basically did what Brandon suggested in his comment—about setting the server paths directly and bypassing the config file. I did this before I ran the module updater or any indexing, so that none of those extra, unwanted, files were added into the exp_assets_files table.

Steps

  1. Backup your current database just in case this doesn't work for you and you want to get back to here.
  2. Restore the database that you backed up in the very first place before all this happened. (You did backup right?). Make sure you delete all tables from the current db and don't just replace them, you want to start clean.
  3. If you are using config['upload_preferences'] array in your config file comment that out.
  4. Disable the RogEE Show Me My Assets! if you have it installed.(Don't think this has anything to do with the issues but just to be safe.)
  5. Go to file upload preferences and set those manually and update them. Check to make sure they are actually updated, if not you will probably still have something referencing them in a config file.
  6. Run the module updater
  7. Go to the assets module and update your indexes.
  8. Un-comment the config['upload_preferences'] you comment out in step 3.

That process worked for me. Hope it helps you.

| improve this answer | |
  • Glad to hear you got Assets up and running. To clarify: Do you have Master Config installed as well, or were you just entering the $config overrides manually in config.php? And, are the $config overrides working for you for normal Assets use (just not for the update itself), or are they completely useless all around for you? – Brandon Kelly Jan 17 '13 at 0:22
  • Yup using the Master Config. $config overrides were working fine for me before trying the update. They also seem to be working fine once everything was indexed properly again. I'm about to update the live server so I will see how that goes and report back. – since1976 Jan 17 '13 at 0:27
  • Thanks for the clarification! We’ll make sure this is fixed for the next update. – Brandon Kelly Jan 17 '13 at 0:36
  • Following that process did work. To confirm, my upload path was not set correctly before setting it using the config override. Brandon, perhaps Assets uses the DB value, and not what it should actually be? – Jason Varga Jan 17 '13 at 0:48
  • @Brandon What Jason says could have something to do with it. exp_upload_prefs is only updated when the update button is submitted in whatever environment you are in. So going from local to another environment is likely to screw things up if Assets is indeed indexing from the stored value in exp_upload_prefs – since1976 Jan 17 '13 at 1:05
1

This should no longer be a problem in the latest version of Assets. (Release Notes). Thank you!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.