1

Assets 2.0.1, EE 2.5.3, BWF 1.5.1, Matrix 2.5.2

When previewing changes to a Better Workflow managed entry, after closing the preview window the page is refreshed. Assets thumbnails are not refreshed with the rest of the page when inside a matrix.

Asset image thumbnails in standalone fields are refreshed.

Before preview: asset images before preview

After preview: enter image description here

2

This was due to the way how BWF processes Matrix rows (or rather, how Matrix initialises them to be compatible with BWF) and the row IDs were being shuffled around.

Obviously, we'll release a new version very soon that fixes these bugs, but, if it's really burning and you can't wait, then feel free to open third_party/assets/views/thumbview/files.php and change the line 15 to this:

$file_class = 'assets-file-'.$max_thumb_width.'x'.$max_thumb_height.'-'.$file->file_id();

That should fix this for you.

0
1

I've been working on a similar issue this week for my Pic Puller fieldtype. Some of what I've been doing might help you out.

I'm not sure how Assets generates its thumbnails, but if its accomplished via JS like I do them with my fieldtype, it may be the same issue I had.

After previewing with BWF my fields within a Matrix had lost their JS functions so no previews were generated.

I ended up altering the Pic Puller fieldtype's JS to listen for the "previewClose" event that BWF broadcasts when it closes it's preview pane and generating the preview images that way.

The callback is here in the Better Workflow docs, look here: http://betterworkflow.electricputty.co.uk/api/#advanced-callbacks

Does that get you closer to a solution?

1
  • 1
    That should definitely be of use to the P&T guys! – Rob Hodges Jan 17 '13 at 17:34
0

There is a known conflict between assets and better workflow that their developers have been aware of for some time. Hopefully, it will be resolved soon!

3
  • 1
    Hi Dorothy, as of version 2.0 of Assets, Better Workflow is now fully compatible. This issue seems to just be a small JS bug rather than a major conflict. – Rob Hodges Jan 17 '13 at 17:33
  • Fantastic!!! Will install both together now. Keep up the great work! – C Calabrese Jan 17 '13 at 18:50
  • All thanks go to the amazing guys at P&T who harnessed our API to add the compatibility :) – Rob Hodges Jan 18 '13 at 9:36
0

Last update: this bug fix has been incorporated into Assets (Release Notes). Thank you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.