3

We are currently running EE 2.5.2 and using the Discussion Forum Module (3.1.8). We have several users who report that they are logged out even when they have checked the 'keep logged in' option. We've triple checked our cookie settings and verified the cookie domain is correct and that the 'keep logged in' option has a cookie with an expiration date set to a year from the log in date. Our user sessions are currently at the default 2 hours, so we are NOT using the 'user_session_ttl' hidden variable. We also have the User Session Type set to 'Cookies Only' in the 'Security and Session Preferences', so I assume any of the session stuff shouldn't matter. All of our cookies to set to the full domain 'www.macobserver.com' and I have not yet tried setting the cookie domain setting in EE as it doesn't seem like we should have to.

My questions are: 1) Are there know issues with cookie logins and the Discussion Forum Module?

2) Should I set the Cookie domain setting anyway even though it's seems like it should be required?

2

There has been known issues with the ExpressionEngine "Remember Me" functionality since August of 2011. It currently is not fixed.

Here is the bug report:
https://support.ellislab.com/bugs/detail/16355

| improve this answer | |
  • I changed my config to use 'cookies only' and I think it gets around this issue, but I'm not sure. For me I seem to be able to maintain a login on multiple browsers for weeks or months. Yet, I still have users who claim that they are getting logged out. Have you had this experience? – Adam Christianson Feb 19 '13 at 23:26
  • I set "Cookies Only" and have to login every day on my end pretty much. – Anna_MediaGirl Feb 20 '13 at 2:19
0

This could potentially be the issue:

http://ellislab.com/forums/viewthread/224902

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.