1

I have an issue where I upload an image through WYGWAM 2.6.3, then using Assets 2.0.1 as a file browser, and when I view the Source it has the IMG tag in there. I save / submit the entry, but when I view it on the live published site it has the IMG tag stripped out leaving just the URL as plain text. There isn't any parameters to my WYGWAM custom field tag and it's just the name of the field. The text formatting around the image shows up, it's just the IMG tag that doesn't. Odd.

Not sure what's going on. Any help?

Assets 2.0.1, WYGWAM 2.6.3, EE 2.5.5

EDITS: Process

I have a WYGWAM field set to Brandon's original "Basic" configuration. WYGWAM 2.6.3, Assets 2.0.1 are being used.

  1. I load the entry, click in the field to where I want to insert the image
  2. Click the little picture icon, it loads Assets, I choose to upload a new image
  3. I upload it
  4. Choose the file in Assets, it inserts my uploaded image.
  5. Next I view the source and I see the IMG tag with the SRC to a URL (that image path does load an image by itself).
  6. I go and view the entry on my page and it just has the URL as plain text, tags are gone.

Those are my steps.

  • Hey Mitchell - are you adding your image code while in source view? Or are you in the normal view when adding your image tag? – Lisa Jan 17 '13 at 21:16
  • I'm using the WYGWAM toolbar to insert an image from Assets 2.0.1. I click the button, upload an image, double click the image to place it, Submit the entry, and then it strips out the IMG tag on the live site. – Mitchell Jan 17 '13 at 22:07
  • I am going to try to reproduce this locally. Could you update your original post with the step-by-step clicks you're using so that I am sure I am doing the same things? Thank you! – Lisa Jan 17 '13 at 22:20
  • I have a WYGWAM field set to Brandon's original "Basic" configuration. WYGWAM 2.6.3, Assets 2.0.1 are being used. I load the entry, click in the field to where I want to insert the image, click the little picture icon, it loads Assets, I choose to upload a new image, I upload it, choose the file in Assets, it inserts my uploaded image. Next I view the source and I see the IMG tag with the SRC to a URL (that image path does load an image by itself). I go and view the entry on my page and it just has the URL as plain text, tags are gone. Those are my steps. – Mitchell Jan 17 '13 at 22:41
  • Hey Mitchell - you mention that you are viewing the source - are you exiting out of the source view before submitting your post? I am having trouble reproducing this either way. Is this a pure Wygwam custom field, or a Matrix? Any other details that might help? – Lisa Jan 18 '13 at 16:34
1

This may be an issue with Channel Videos. I'll consider this response from Lisa Wess as an answer in that it isn't a WYGWAM issue. Thank you Lisa for helping out.

| improve this answer | |
  • My pleasure, Mitchell! – Lisa Jan 23 '13 at 19:09
  • Turns out it was user error on my end. Reminder: don't forget to enable image URL's in custom fields under Channel preferences. #facepalm – Mitchell Feb 4 '13 at 6:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.