3

I'm doing an upgrade of a site from 2.2.x to 2.5.5. I've moved all of the files up, and prepped for the upgrade but when I run the upgrade wizard it is literally stuck on this screen: http://cl.ly/image/3r3L16453428

It will flash to say "Starting next step..." and then back to 2.3.0

Video is here: http://www.screencast.com/t/R7KzkLAld

Anyone else ever see this issue?

6
  • The last time I saw something remotely like this, it was a permissions issue with config.php. But if you successfully upgraded from 2.2 to 2.3 then that seems unlikely.
    – TJ Draper
    Jan 18 '13 at 17:29
  • Thanks TJ, I think you're on the right track. After I read this, I found this link: ellislab.com/forums/viewthread/161299/#775680 Will let you know Jan 18 '13 at 17:35
  • Mike, if that forum post helps you fix your problem, please come back here and post a detailed answer and accept your answer as correct by clicking on the checkmark to the left of the answer. This will help others who might have this problem going forward.
    – Anna_MediaGirl
    Jan 19 '13 at 1:27
  • Sounds good. I was actually able to do the upgrade but, wow, this is some crazy voodoo crap from EL. Basically the upgrade is still working but you have to restart it over and over again. It seems extremely sketchy. Jan 21 '13 at 17:59
  • 1
    Could you give details of the fix here? I'm having the same issue but that thread on the forums doesn't really seem to apply. Looking for any clues that might get me over this hurdle.
    – foamcow
    Feb 1 '13 at 12:26
1

I've had the same thing happen. And my solution was just as you described - restarting the upgrade after seeing the progress stall out. It did seem very strange to have to resort to such methods. However, I haven't seen any problems with the sites upgraded that way. I've seen it happen on multiple hosting platforms too. I use DevDemon's Updater now and don't run into it anymore.

0

I had this issue. I think I managed to fix it by disabling javascript on my browser to stop the "ajax=yes" parameter.

However, I also switched back and forth between two browsers and cleared my page cache repeatedly. It was a bit of a process. :)

I would try seeing if disabling javascript fixes the issue first since that was my last step. This can be quickly enabled/disabled using the web developer extension. See: Web developer firefox or Web Developer Chrome

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.