3

I'm currently in the process of upgrading a pretty complex EE1 site to 2.5.3. One of the thornier issues I've hit concerns EE2's handling of query strings and the interaction of this with native pagination.

The site uses Solspace's Super Search module and I'm removing index.php via the standard exclude method, on EE1 I therefore had URLs of the format:

http://example.com/path/to/search&key=value&key2=value2.

On EE2.5.3, though super search works fine with URLs of this format, EE shows the $_GET array as empty (as shown in the template debugger output). I need to be able to access values in GET in my templates (I'm using Mo'Variables for this), so have reformatted my search URLs to use a "?" instead like so:

http://example.com/path/to/search?key=value.

This works great for both super search and mo variables, but breaks on paginated output, as the pagination segment is appended to the end of the query string, like so:

http://example.com/path/to/search?key=value/P15

Which breaks Super Search, whereas what I need is to prepend the pagination segment to the query string:

http://example.com/path/to/search/P15?key=value

I'm reasonably sure there must be a way around this, even if it involves an addon instead of native pagination: devot-EE also uses Super Search and has a URL structure/pagination just like what I'm looking to achieve, but I'm running up against a brick wall at the moment. Any and all bright ideas gratefully received.

Edit: as noted in the comments to below Devot-ee now uses Low Search instead of Super Search

1

Did you try with the 'paginate_base' parameter in the exp:super_search:results tag? Weirdly, I don't find any reference to this parameter in the documentation, but I'm using it in all my sites.

| improve this answer | |
  • Hey, thanks for the reply but unfortunately paginate_base doesn't do the trick - the pagination segment is still appended to the end of the URL (inc query string) rather than between the template path and query string – Tom Davies Nov 16 '12 at 14:14
  • In fact I'm not sure that SuperSearch like the ? so much. Here I have /search/search&keywords=test&start=0/, then /search/search&keywords=test&start=0/P10/ for the next page, which works fine. But not sure that Mo Vars will work without the ?... Maybe you could use POST instead of GET? – pvledoux Nov 16 '12 at 14:30
  • I need to use GET so that search results are bookmarkable. I'm pretty sure this can be made to work - see the devotee page I linked to above... – Tom Davies Nov 16 '12 at 14:34
  • In case it helps with the troubleshooting to know this, Devot:ee used to use Super Search but switched to using Low Search a little while back. – Alex Kendrick Nov 16 '12 at 15:24
  • Thanks for that - now feel bad for sending them an email asking the same qn. – Tom Davies Nov 16 '12 at 15:26
1

Unfortunately I was unable to resolve this with SuperSearch, so ultimately I decided to migrate to Low Search instead, which was a reasonably painless process and seems to be working well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.