1

I have EE v2.5.3 and Freeform Pro 4.0.10 among other things.

When submitting forms with admin notify turned on I get a server timeout error. The form data still submits to the db and I still get a notification email but the server hangs and eventually times out instead of loading the return page.

If I turn on admin notify it works properly, but obviously no notification, which I very much need.

3
  • What settings do you have in place in your install for mailing? SMTP? PHPMail?
    – Anna_MediaGirl
    Commented Jan 23, 2013 at 17:18
  • SMTP in place. It was working last week. Not sure what happened. Commented Jan 23, 2013 at 18:48
  • I'm using the Freeform Pro notifications. Never actually set up the SMPT stuff for control panel emails. Commented Jan 23, 2013 at 18:59

1 Answer 1

0

This sounds like it's an issue on your server since it was working and now is not.

I'd first test to see if you are having timeouts when sending from the Communicate page in EE. If you can't send from the Communicate page, enable Email Debugging to see what's going on.

Also check your PHP error logs to see what you see. An error related to the timeout may exist there.

If necessary, contact your host to see if they have changed anything on the server related to PHPMail/SMTP (I'm not clear from your comment which one you are using exactly)... Send them the info you find in the debugging and logs.

1
  • The host did change something. Switched to Sendmail in the mail settings and it works now. Thank you. Commented Jan 23, 2013 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.