2

We have a client in which we've set up Freeform Pro and have several forms. We've got the forms working properly, but all emails are getting directed to their Spam folder.

The client is using Outlook, as part of the Office 365 package, and have whitelisted the email address that is sending the emails.

Is there any way to change the email address that Freeform is using to send these emails, or be able to mark the emails generated by Freeform not spam?

EE Version: 2.5.3 Freeform: 4.0.7

Thanks in advance!

0

It's possible the addon is using the email address set on the Email Configuration page in the CP as the from address. If it matches the from address you are seeing, change it and retest.

Whitelisting the email address is what should stop Outlook from marking as spam. If the emails continue to be marked as spam, I'd say it's not being whitelisted correctly.

2
  • I'll try this -- I think this is what we set it up with initially, and couldn't remember where to find this. I'll try it, have the client try it out and report back. – dauble Jan 24 '13 at 16:24
  • You're welcome. If it does the trick, make sure to select the answer as "correct" by clicking on the checkmark to the left of the answer. – Anna_MediaGirl Jan 24 '13 at 16:28
1

You have full control over the "from" address in Freeform's notification settings.

What you might want to do is set a "reply-to" address as well. Set the "From" address to a known, whitelisted address that your mail server will accept, and then use the submitter's email as the "reply-to" address. This lets the received directly reply to the form sender, while allowing the message to be properly received by your server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.