1

I updated to matrix 2.5.3 from version 2.4.3 on my mamp test setup and notice the following issues.

On the prior version matrix was outputting prices using a comma for the thousands_sep parameter. The new version of matrix no longer outputs the comma and in addition, adds decimal places:

Version 2.4.3 output: $279,950

Version 2.5.3 output: $279950.00

I notice the decimal settings now in the matrix field setup which I've used to remove the decimal places. However, I cannot find a way to get matrix 2.5.3 to use the thousands_sep as it was previously. Any solutions?

Here is the code, which did not change. neighborhood_plan_price is the variable in question:

                    <tbody>
                    {exp:channel:entries channel="neighborhood" dynamic="no" sort="asc" orderby="neighborhood_city" status="Not Closed" disable="categories|category_fields|member_data|pagination"}
                    <tr url="{path='neighborhood-detail/{url_title}'}">
                        <td><a href="{path='neighborhood-detail/{url_title}'}">{title}</a></td>
                        <td>{neighborhood_city}, {neighborhood_state}</td>
                                {if status == "Coming Soon"}
                                <td>Coming soon</td>
                                {if:elseif status == "Sold Out"}
                                <td>Sold Out</td>
                                {if:else}
                                <td class="dollar">{neighborhood_plans limit="1"}{neighborhood_plan_price}{/neighborhood_plans}</td>
                                {/if}
                    </tr>
                    {/exp:channel:entries}  
                </tbody>

Matrix field setup in version 2.5.3

11
  • Hey Stephen - could you add some context to your post with a screenshot of your Matrix settings, as well as your template code? Thank you!
    – Lisa
    Jan 24 '13 at 19:12
  • Code and screenshot added.
    – Stephen
    Jan 24 '13 at 19:24
  • Alright. What are you entering on the publish screen, Stephen? Exactly so I can copy/paste it. I tried a variety of combinations of your number and get a variety of errors back so I can't reproduce your exact issue.
    – Lisa
    Jan 24 '13 at 20:06
  • Whoops, left that detail out. In the publish screen 279950 is entered. No decimals, commas or dollar sign. Just the number digits.
    – Stephen
    Jan 24 '13 at 20:16
  • Alright. I got ya. When I output this in the template I Just get the straight number, no formatting at all. I can't get the parameter to ouptut much at all for that, comma or not. Let me investigate further. Thank you Stephen!
    – Lisa
    Jan 24 '13 at 20:26

Browse other questions tagged or ask your own question.