4

Hullo

We've a 4 stage checkout process working (Select Billing, Email Address & Passwords, then Optional Shipping Stage, then Delivery/Shipping Method, then Payment Method). This all works lovely as far as getting an order through the system, with all the right data in the order details. A member account is created, with the matching password, however all of the mapped fields are nowhere to be seen.

ExpressionEngine 2.5.3 | Expresso Store 1.6.2

Any ideas? Have we missed a magic tag? We are using register_member field in the checkout tag.

Many thanks

Geoff

1
  • Remember to mark an answer as correct if it solves your problem. Mar 28, 2013 at 21:56

2 Answers 2

3

This is a known issue in Store 1.6.2. Mapped member fields aren't updated for customers who register an account during checkout (because the account is currently created after the mapped fields are processed). For all existing users the mapped fields should be working correctly.

UPDATE: This issue has been fixed in Store 1.6.3.

4
  • Thanks Adrian, any eta on the new release? Jan 28, 2013 at 15:06
  • Not currently, but feel free to email [email protected] and we will keep you updated :) Jan 29, 2013 at 5:20
  • This is a bit concerning... this functionality is a showstopper for us. Any news on when this issue will be fixed please?
    – Tomtids
    Feb 8, 2013 at 13:31
  • New version should be within the next couple weeks. If you need it sooner, email [email protected] and we can get you a hotfix. Feb 9, 2013 at 4:09
1

Did you map them in the Store Order Fields panel? Order Fields allows you to map order fields to member fields:

Store > Settings > Order Fields

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.