0

Error: Thumbnail could not be created for the image. Please make sure the thumbnail directory is writable.

I've recently upgraded a client's site to v2.5.5 and they are now not able to upload images. I've verified all permissions are correct and I've also reviewed the EE Wizard details (no errors there either). They were successfully uploading images in the weeks prior to the upgrade.

Any idea what could be causing this?

  • EE 2.5.5
  • Windows 2008 Server
  • PHP 5.3.10
  • Have you checked the File Upload Preferences paths and the directory permissions on both the parent upload directory and its _thumbs directory? – Derek Hogue Jan 29 '13 at 2:43
  • Hi Derek! Yes, I checked to make sure the proper permissions are set on the upload directory and it's _thumbs sub-directory. They are set correctly as they always have been prior to upgrading. – ShawnCBerg Jan 29 '13 at 3:22
2

Figured this out today. We were using relative server and URL paths in the file upload preference settings. Example:

Server Path: /websites/domain.com/uploads/
URL: /uploads/

After changing them to absolute paths:

Server Path: E:/websites/domain.com/uploads/
URL: http://www.domain.com/uploads/

Everything works properly. We never had problems previously with the relative paths, though, so something must have changed in the latest version.

  • Perhaps this is Windows-server-related, as I still use relative paths for all upload directories under 2.5.5, no issues. Good to know though. – Derek Hogue Jan 29 '13 at 21:22
  • It very well could be. This was definitely on a Windows server as you can see by the server path. – ShawnCBerg Jan 30 '13 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.