5

I'm using Expression Engine v2.5.5 and Assets v2.0.3 with mulitple upload folders.

When using the file manager in IE8 clicking on the folder links does not update the view to show contents of that folder.

Does Assets 2 support IE8?

5
  • 1
    I'm not even sure I have IE8 to test on. Do you see any JS errors showing up in IE8, Kevin? What if you try in compatability mode? – Lisa Jan 30 '13 at 19:06
  • Hi Lisa, unfortunately no javascript errors show up and in compatability mode the file view doesn't load at all. A javascript syntax error does show up in this mode but fixing it has no effect. Of course in an ideal world my target users wouldn't use IE8... – Kevin Lees Jan 30 '13 at 22:27
  • Hey Kevin - I am going to submit this as a bug. Thank you for reporting it! – Lisa Jan 31 '13 at 1:21
  • I just confirmed this in IE8 and Assets 2.0.4. – Ian Pitts Feb 1 '13 at 15:18
  • This bug should be fixed in the next Assets update. Thanks for reporting this! – Lisa Apr 29 '13 at 18:56
3

The Garnish UI library used by Assets tests for a single left click using the mousedown and mouseup events.

Unfortunately IE 8 returns the value of 1 when the left mouse button is clicked, and the garnish library tests for 0, which is what the W3C says it should be.

Please see http://www.quirksmode.org/js/events_properties.html#button

I've had to fix this for a client deadline, so it's a bit of a hack but not too bad as Pixel and Tonic provides un-minified js files.

First change the helper.php in system/expressionengine/third_party/assets directory to load the un-minified js file, on line 157 change:

$filename = 'garnish-'.self::$_garnish_version.'.min.js';

to:

$filename = 'garnish-'.self::$_garnish_version.'.js';

Next change the garnish-0.1.js in the themes/third_party/assets/lib folder. There are 4 occurrences of the string:

ev.button != Garnish.PRIMARY_CLICK

and replace it with:

ev.button === Garnish.SECONDARY_CLICK

I've not tested this thoroughly but it's sorted my problem out for now.

-1

I'm still seeing this behaviour in Assets v2.1.3 - the client (using IE8 on Win7) has complained that the 'Add Files' button doesn't become active once a file has been selected via the Assets slidedown window. I can replicate this behaviour. They can double-click to select, fortunately, but we still seem to have compatibility problems.

Lisa: Did your bug get cleared?

I tried Kevin Lees's fix but it didn't work for me. There now seems to be a config setting $EE->config->item('assets_use_uncompressed_js') - but I'm not clear on how to change this!

EDIT: I got in touch with Pixel & Tonic and they confirmed the existence of some IE8 incompatibilities which will be addressed in the next Assets release (2.1.4).

1
  • Please post this as a new question, rather than using the "Answer" field. The Answer field is only for genuine solutions. – Adrian Macneil Jun 29 '13 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.