3

After updating to Assets 2.0.4 on EE 2.5.1, I noticed that that when I view a custom Assets field, the previously defined upload directories are no longer checked.

After some digging around the assets database tables, I noticed some odd inconsistencies: http://jon.ee/image/2l0B2w2v3A3Y (Screenshot)

All of my images display properly on the front-end.

  • What could be causing the upload paths to be unchecked on custom Assets filled
  • Should the full_path column be filled in, and is this causing the issue?
6
  • From what version did you upgrade from, Jon? Also, full_path column should be empty for top level folders (parent_id set to NULL). – Andris Sevcenko Feb 1 '13 at 7:57
  • I upgraded from 1.2.2. Looks like database is correct then. I didn't fully understand the changes Assets 2 made, so it made me nervous that the column was empty. – Jon Horton Feb 1 '13 at 22:35
  • That said, My Upload directories aren't checked when viewing a custom Assets field. Any ideas on this one? – Jon Horton Feb 1 '13 at 22:36
  • So updating from 1 to 2 lost your Assets field settings? (Namely - allowed upload folders) – Andris Sevcenko Feb 3 '13 at 15:30
  • 1
    It seems that all of the settings are still there, the boxes just aren't checked. – Jon Horton Feb 4 '13 at 15:08
0

This was a bug that has been fixed since Assets 2.2. See changelog.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.