Yesterday I went live with a site from my development server (WAMP) to my production server (LAMP). I made all of my changes to paths and DB, and while the site was coming up, I was having some issues getting into the CP. I think it was a URL issue as the domain name under which I was developing was different than the live site. I finally got it straightened out and was able to get logged in.

Somewhere along the line, I must have made an adjustment that then broke things. The front end of the site still works, but I’m now getting the dreaded WSoD when accessing the CP. Very strange since it was workign fine. So somewhere I must have made an adjustment that broke things. Retracing my steps hasn't solved anything. Hopefully the following provides something that triggers an idea.

When logging in, it goes to the authenticate URL, then to the home page URL where it gives me the WSoD.

I've tried altering the URL to see if I could access other parts of the CP. Here are the results:

  • WSoD – any of the add-ons (modules, accessories, extensions, field-types, plugins)
  • WSoD – home page
  • CAN ACCESS – templates, template manager, snippets, etc.
  • CAN ACCESS – area to manage members and groups

I’ve tried to turn on debugging in my admin.php template, as well as the index.php and system/index.php. Doing so provides no additional information. I’ve also re-uploaded the files and dropped the DB and imported again.

I spent several hours last night trying everything I could think of. So any help is very much appreciated. The answer is probably in front of me, but my head is hurting from banging it on the wall!


2 Answers 2


My first suggestion would be to start your migration over. Move files and database freshly since things did work when you first moved over.

Then before you log into the CP on the production server, clear your browser cache and cookies, then add this to your config.php file:

$config['cookie_domain'] = "";
$config['cookie_path'] = "";
$config['cookie_prefix'] = "";
$config['admin_session_type'] = "s";
$config['user_session_type'] = "c";
$config['require_ip_for_login'] = "n";
$config['require_ip_for_posting'] = "n"; 
$config['secure_forms'] = "n";  
  • Thanks Anna. Not sure what part of that was the problem, but after deleting and re-uploading everything, I was able to get back into the CP. Odd. Thanks!
    – Todd
    Commented Feb 8, 2013 at 0:47
  • OK, so I spoke too soon. I hadn't added the information to the config.php file because I was able to get in without it. However, after my session expired, now I can't get in again. If I add the above to my config.php, then it freezes on the "authenticate" part. If I remove it, it just keeps bouncing me to the login. Grrr....
    – Todd
    Commented Feb 8, 2013 at 2:22
  • Try adding in each line by line.
    – Anna_MediaGirl
    Commented Feb 8, 2013 at 6:14
  • And clear cache and cookies.
    – Anna_MediaGirl
    Commented Feb 8, 2013 at 6:15
  • I did that last night, and the only difference it made was whether it froze on the authenticate part, or just kicked me back to the login screen. The only thing that i can think of is this - when I was developing the site locally, I used a domain name originalsite.com. Before we went live they wanted to switch it to newsite.com. I'm not sure if somewhere, somehow, that is what is confusing things? So I started a completely fresh install with the newsite.com and will see what happens....
    – Todd
    Commented Feb 8, 2013 at 14:34

OK, so I contacted EllisLab Support for assistance - and they were fantastic. It turns out that I had a second (and possibly older/different) Switchee folder in my third_party add-ons folder (I had one folder "switchee" and another "croxton-Switchee-b813d5b". As soon as I removed the latter, I was able to log in. They said that the error was suppressed due to an @ on the include. They would look into removing that for easier debugging in the future.

The thing that is still strange to me is that my local dev site still works just fine (with the duplicate folder). But I'm not going to spend any more time trying to figure out why. It's working!

Thanks again to Alex, and especially Anna for your continued attempts to assist!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.