0

I am running into an error when editing content in Chrome on Mac. I upgraded to Wygwam v2.7 to ensure I was using the latest version. I am using EE v2.5.3.

When adjusting paragraph text, if I delete the break and merge it with the previous paragraph then create a new paragraph, SPAN tags are being added. You can see the example in this video, http://cl.ly/3S2N0z2p1G3p

Any ideas what is causing the issue?

6
  • Hey Mike - if you try that on the CKEditor demo page, does the problem show up? ckeditor.com/demo. Please let me know, thank you! – Lisa Feb 4 '13 at 17:37
  • In the demo, a SPAN tag is added but it has line-height instead of font-size. <span style="line-height: 1.6em;"> – Mike Zens Feb 4 '13 at 17:39
  • The undesirable part is the span tag at all, yes? It sounds like it may be a CKE issue here. – Lisa Feb 4 '13 at 17:40
  • Yes, in the error I am running into, the span tag is using the font-size style. This causes some issues on the front-end of the site because the font-size is being adjusted. So there isn't much to do if it is an issue with CKEditor? – Mike Zens Feb 4 '13 at 17:44
  • Well, we're not on CKE 4 yet, but there is an existing bug report: dev.ckeditor.com/ticket/9998 so it does look like a CKE issue, unfortunately. :( – Lisa Feb 4 '13 at 17:50
2

It appears that this may be a bug with CKEditor That bug report is for v4, but looks like it may also impact v3.x as well.

2

As a good stop gap solution, Tyssen suggested that I add this code to my CSS: span[style]: line-height: inherit !important; font-size: inherit !important;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.