2

Looks like Assets, when creating the "_thumbs" folder... is using "666" permissions... This is creating an issue with being able to access files through my standard sftp account. Unless the file is 777 I cannot touch it.

Is there a reason the "_thumbs" is not 777 ? Is this a bug possibly?

2
  • I'm confused on a lot of points here - 666 is a file you should be able to manage, and even things like config.php should be set to 666. I'd talk to your host about that. As for the 666 permissions - I believe this is actually something set in PHP, but I will double check with the team.
    – Lisa
    Commented Feb 4, 2013 at 20:32
  • Hi Roi, welcome to Stack Exchange. Please take a moment to read through our FAQ - you need to phrase your post as a question, with evidence of what you have tried to solve the problem so far. At the moment it's more of a vague observation than a question. Also this sounds more like an issue with your hosting than Assets. Can you try to add some more detail to the original post? Thanks Commented Feb 5, 2013 at 5:59

1 Answer 1

1

Roi,

We're using EE's filemanager to handle thumbnail creation, specifically below:

return $this->EE->filemanager->create_thumb($image_path, $preferences);

So this is something done by EE. Some hosts will put a mask on the level of permissions PHP scripts can set - so if a script tries to set one permission, that mask may change it. The latter is something to ask of your host.

But again, 666 permissions should be just fine for you to work with, so I'd also follow up on that point with your hosting provider.

-Lisa

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.