2

I'm sure this one is going to be pretty simple - but I'm banging my head against the wall here. It's been a while since I've worked on a 1.x build.

I have a client site which was just migrated to a new server. Following the migration, the homepage template loads correctly, the CP loads correctly. However, all subsequent page loads on the forward facing site redirect to the homepage.

The .htaccess file (removing index.php) is unchanged. I even had this site up on the SAME hosting environment temporarily as staging.clientname.com where everything worked perfectly.

However, as soon as I point the document root of the main domain to the document root of site (which was also in there as staging.clientname.com) the internal templates redirect.

I'm assuming this is an obvious config that I am just forgetting about.

Thanks so much for your help,

Michael

2

Michael -

Have you enabled 'Force Query Strings' in Admin > System Preferences > Output and Debugging Preferences (this is from memory, sorry if the breadcrumb is a bit off).

I suspect that you just need to have a question mark after index.php - you can remove it with .htaccess, but that is the most common cause here and usually happens on installations where PHP is run as CGI.

The system preference above will add the question mark to all EE generated URLs.

I hope that helps!

-Lisa

| improve this answer | |
  • Hey Lisa! I'm working in sort of an 'over the shoulder' capacity helping someone else do this - and they have gone for the day, but I will try this first thing tomorrow morning and report back. I appreciate it! – Michael Witwicki Feb 4 '13 at 22:58
  • Awesome! There are other possibilities if that doesn't work, one is changing the qtype in index.php. Ah such memories! – Lisa Feb 5 '13 at 0:18
  • My pleasure, thanks for posting what was going on! – Lisa Feb 5 '13 at 17:57
0

It ended up, in this case, being a misconfigured apache configuration. The client had AllowOverride set to No. Thanks so much for your assistance!

| improve this answer | |
  • Psst - Mark your answer as the solution to the question. – Mark J. Reeves Feb 5 '13 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.