I am using DevDemon Updater for the first time, so bear with me if I am being dense.

I updated the site from v2.3 to v2.5.3 last night along with Matrix and Wygwam. But for some reason, I noticed one of my templates is just white now.

I am looking the template over to see if dynamic="no" is getting me or what not, but it was working before the update, so I wanted to see if this has been experienced before.


  • Posting the code of the problem template would be helpful. – kmgdev Nov 28 '12 at 2:40

I don't think it is Updater or your fault. The issue is most likely that the new version of ExpressionEngine is causing an error on some older code. Turn on errors in your main index.php file and see what it gives you. It should be easy to debug from there.

| improve this answer | |
  • okay thanks, seems there are other issues with 2.5.3 than i thought. – Tad Ward Nov 28 '12 at 1:33

This is very likely due to an add-on (or two) that needs to be updated for 2.4+ because of a change EllisLab made to the pagination class with that release. You can enable debiugging on the template to catch the name of the add-on in question, than make sure to update it.

I ran into this very issue only last week updating a site from 2.1.3 to 2.5.3. I had to update at least four add-ons because of the pagination issue. See pagination notes in the 2.4.0 changelog. Cuplrits for me were a few Solspace add-ons and a Pixel & Tonic add-on.

| improve this answer | |
  • 1
    I was thinking an add-on issue. After further investigation it was a {if:else} tag on the template that was causing it to go white. But I use that tag on other templates and no issues. – Tad Ward Nov 28 '12 at 1:51
  • I've been updating several sites from 2.1 up to 2.5.3 lately and my process is download updated versions of each addon. Update EE, then update each addon and finally check that everything is working fine. it may seem like more work, but in the end I think it saves me time as I've got it all up to date. – CreateSean Nov 28 '12 at 2:16
  • 1
    Sean, exactly. After my looking for issue, it finally turned out they client was uploading raw images to the site, so it was crashing the template related to that entry. Time to update the lightbox script i was using to allow for additional image resizing. – Tad Ward Nov 28 '12 at 2:38

I have had that happen before where a template just died... I deleted it and restored from a backup template and, like magic, it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.