1

When attempting to logout using the freemember logout URL tag the page is re-directing to a blank page with the desired url path output: https://www.site-name.com/?ACT=56&return_url=%2F

I have also tried other paths, that is other than redirecting to the home page.

Any ideas?

2

Blank page usually means there is some PHP or MySQL error, but it is suppressed by EE debugging level. Try setting "Show error to everyone" in Output Preferences and see if you get any message.

| improve this answer | |
1

Try setting $debug = 1; in your index.php file.

This will force EE to display any PHP errors that might be being hidden on that page.

Alternatively, you might have some crazy htaccess rules which are breaking the ?ACT URL (this is an EE action URL used by FreeMember, in this case to log out the current user).

| improve this answer | |
0

Are you using the {exp:freemember:logout_url} trying setting return="example/page"

{exp:freemember:logout_url return="example/page"}
| improve this answer | |
  • Also you can view all Freemember documentation here (github.com/expressodev/freemember/wiki). – philecker Feb 7 '13 at 22:08
  • Other than that suggestion, without seeing your template, config, etc. I don't anyone will be much help. – philecker Feb 7 '13 at 22:18
  • here is the tag template in use: {exp:freemember:logout_url return="/"} With a path other than the "/" is returns the blank page with: site-name.com/?ACT=56&return_url=example%2Fpage – renrez Feb 7 '13 at 23:35
  • What version of EE and Freemember are you using, I tested with EECMS 2.5.5 and Freemember 2.1.1 and had no issues. – philecker Feb 7 '13 at 23:41
  • Yes, i am using both 2.5.5 and 2.1.1 – renrez Feb 9 '13 at 22:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.