4

I've tried adding dynamic="no".. removing curly brackets.. adding status="publish" since that's the status that a blog post has to be to display.. all no luck so far. Here's the rss file

code removed due to update

I'm using structure, so that would explain the {page_url}

Update

My blogs channel is "blog" but i switched the channel to "personal_trainer_directory" just to see if other channels would work, and it did.. So what could be causing the issue with this now?

Current code:

{preload_replace:master_channel_name="blog"}
{exp:rss:feed channel="{master_channel_name}"}

<?xml version="1.0" encoding="{encoding}"?>
<rss version="2.0"
        xmlns:dc="http://purl.org/dc/elements/1.1/"
        xmlns:sy="http://purl.org/rss/1.0/modules/syndication/"
        xmlns:admin="http://webns.net/mvcb/"
        xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
        xmlns:content="http://purl.org/rss/1.0/modules/content/">

        <channel>

        <title><![CDATA[Blog]]></title>
        <link>{channel_url}</link>
        <description>{channel_description}</description>
        <dc:language>{channel_language}</dc:language>
        <dc:creator>{email}</dc:creator>
        <dc:rights>Copyright {gmt_date format="%Y"}</dc:rights>
        <dc:date>{gmt_date format="%Y-%m-%dT%H:%i:%s%Q"}</dc:date>
        <admin:generatorAgent rdf:resource="http://expressionengine.com/" />

{exp:channel:entries channel="{master_channel_name}" limit="10" dynamic_start="no" disable="member_data|pagination"}
        <item>
            <title><![CDATA[{title}]]></title>
            <link>{page_url}</link>
            <guid>{page_url}#When:{gmt_entry_date format="%H:%i:%sZ"}</guid>
            <description><![CDATA[{article_body}]]></description>
            <dc:subject><![CDATA[{categories backspace="1"}{category_name}, {/categories}]]></dc:subject>
            <dc:date>{gmt_entry_date format="%Y-%m-%dT%H:%i:%s%Q"}</dc:date>
        </item>
{/exp:channel:entries}

        </channel>
</rss>

{/exp:rss:feed}

final working rss feed:

{preload_replace:master_channel_name="blog"}
{exp:rss:feed channel="{master_channel_name}" status="open|publish"}

<?xml version="1.0" encoding="{encoding}"?>
<rss version="2.0"
        xmlns:dc="http://purl.org/dc/elements/1.1/"
        xmlns:sy="http://purl.org/rss/1.0/modules/syndication/"
        xmlns:admin="http://webns.net/mvcb/"
        xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
        xmlns:content="http://purl.org/rss/1.0/modules/content/">

        <channel>

        <title><![CDATA[Blog]]></title>
        <link>{channel_url}</link>
        <description>{channel_description}</description>
        <dc:language>{channel_language}</dc:language>
        <dc:creator>{email}</dc:creator>
        <dc:rights>Copyright {gmt_date format="%Y"}</dc:rights>
        <dc:date>{gmt_date format="%Y-%m-%dT%H:%i:%s%Q"}</dc:date>
        <admin:generatorAgent rdf:resource="http://expressionengine.com/" />

{exp:channel:entries channel="{master_channel_name}" limit="10" dynamic_start="on" disable="member_data|pagination" status="open|publish"}
        <item>
            <title><![CDATA[{title}]]></title>
            <link>{page_url}</link>
            <guid>{page_url}#When:{gmt_entry_date format="%H:%i:%sZ"}</guid>
            <description><![CDATA[{article_body}]]></description>
            <dc:subject><![CDATA[{categories backspace="1"}{category_name}, {/categories}]]></dc:subject>
            <dc:date>{gmt_entry_date format="%Y-%m-%dT%H:%i:%s%Q"}</dc:date>
        </item>
{/exp:channel:entries}

        </channel>
</rss>

{/exp:rss:feed}
3

I copied and pasted your template code into a new template in a site in my dev environment. The only value I changed was the master_channel_name value to match one of my channels.

I see all entries being output.

You mention:

adding status="publish" since that's the status that a blog post has to be to display.

I would closely examine your custom Status values, or stick with open|closed to try to troubleshoot this further.

| improve this answer | |
  • @mark-j-reeves Thank you! this got me a bit further.. I changed one of the statuses on a post to "open" and the post is displaying in the rss.. is there anything special that i have to do to get the "publish" status to display in the rss? – Joe Bobby Feb 8 '13 at 15:09
  • You'll need to add status="open|publish" to your exp:channel:entries tag. By default, that tag will only assume open. – Mark J. Reeves Feb 8 '13 at 15:09
  • I found something strange.. if I add status="open|publish" still nothing displays, but if i switch 1 post to the status of open` they display.. is there any explanation why that happens so i can understand for the future? – Joe Bobby Feb 8 '13 at 15:14
  • Thats the right syntax (ellislab.com/expressionengine/user-guide/modules/channel/…). Are you sure you're writing "publish" the exact same way you've defined it in your custom statuses? – Mark J. Reeves Feb 8 '13 at 15:16
  • I got it working with all posts on publish instead of 1 post being on open now :) i had to add status="open|publish" to the exp:channel:entries` and exp:rss:feed :) thanks for the help! – Joe Bobby Feb 8 '13 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.