2

I've been using the Focus Labs bootstrap with great success for my last few projects. However just now I ran into a snag. I exported my production database, imported it locally, and now the site does not work and I get these errors:

A PHP Error was encountered
Severity: Notice
Message: Undefined property: EE::$session
Filename: libraries/Functions.php
Line Number: 377

A PHP Error was encountered
Severity: Notice
Message: Trying to get property of non-object
Filename: libraries/Functions.php
Line Number: 377

A PHP Error was encountered
Severity: Warning
Message: Cannot modify header information - headers already sent by (output started at    /Users/User/Sites/example/system/codeigniter/system/core/Exceptions.php:170)
Filename: libraries/Functions.php
Line Number: 402

If I turn off extensions in my config file things do work, sans extensions.

I did another export/import of the database to be sure, compared all my add on versions (all are the same), went back to my old local database (that works), and sync'd all my templates to the new production database. None of these fixed the issue.

Turning off all extensions via the database (Sequel Pro) allowed me to isolate it to Force SSL and specifically the on_page_load method.

At least now I can work locally, but would like to get things running smoothly again. I've posted in the Devot-ee forums and will link back to here.

  • Could you tell us what extensions you have enabled on production? – Jeremy Gimbel Feb 11 '13 at 4:39
  • Typically, the best way to troubleshoot this kind of issue is to manually disable all your extensions and then enable them one at a time until you find the one that's causing the issue. If you step through that process and still get stuck please do add details of the xtn to your question to better help us help you. – Tom Davies Feb 11 '13 at 12:25
  • I tried to do this, but the problem I ran into was with them on the site would not load. With them off I could not activate them one at a time. Then (after a weekend to rest my brain) I remembered Sequel Pro will let me do this (duh). exp_extention, turn them all off (set to "n"), and voila! The culprit: ForceSSL, and specifically the on_page_load method. – Doug Feb 11 '13 at 19:00
  • Did your old db have the force_ssl extention installed? – JohnWBaxter Feb 25 '13 at 10:19
2

I suspect there are some sessions/cookies referenced in the DB that that exist on the production server, but not the other environment; removing said references from the DB could resolve it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.