I am fairly new to ExpressionEngine, I have noticed my admin page is missing "Channel", "template", and "template group" as seen on this page:


Can someone please advise?

Many thanks.

  • Are you logged in as a Super Admin? Did you install and set up EE or are you a user who someone created an account for? Feb 11 '13 at 19:51
  • hi there, i did not install nor did i set up EE, i was merely given this account. I am logged in as admin only
    – godzilla
    Feb 11 '13 at 19:53

I expect the developer who configured the site restricted your admin privileges so that you can create entries and post content to the site, but not configure the website.

Channels, template groups and templates are all underlying components that structure what the site supports and how it renders. They all need to be accompanied by code to work on the website, as opposed to posting/editing content entries, which the templates you have in place should already match.

  • thanks for your response, can these privileges be changed? I Can't meet requirements without adding new channels
    – godzilla
    Feb 11 '13 at 20:31
  • Yes, but a Super Admin needs to login and do that. Feb 11 '13 at 20:32
  • Bast would be to discuss this with the person who set the site up. He/she can eiher add the channel you need or give you the rights to set them up on your own. But you should be aware, that with extended rights comes extended responsibility. As a Super Admin you have the potential to destroy a site.
    – awa
    Feb 12 '13 at 7:46

It sounds like you need to be set as a SuperAdmin if you do not have access to a SuperAdmin that can change your account type you have a few options.

The easiest would be to:

If you have access to Tools > Data > SQL Manager > Database Query Form you can simply run the following command

UPDATE exp_members SET group_id=1 WHERE member_id=X

Where "X" is your member_id. If you need to find out your member_id you can goto Members > View All and then search for your username.

The other option would be to reset the initial Super Admins password to something along the lines of "password" for you to login and change it.

To do that you would want to run the following command

UPDATE exp_members SET password='5f4dcc3b5aa765d61d8327deb882cf99' WHERE member_id=1

This can also be done from phpMyAdmin if you do not have access to the Tools menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.