1

I recently migrated my localhost EE website to a remote Linux server. Now, a few (5 out of about 35) of my pages are returning this error (Google Chrome for Win7):

No data received. Unable to load the webpage because the server sent no data. Here are some suggestions: Reload this webpage later. Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

In Firefox for Windows, the error is:

The connection to the server was reset while the page was loading.

The behavior is intermittent on some of the pages. Sometimes you can refresh the page several times and get it to load.

I am using Structure 3.3.8 as well as Low Variables, CE Image, Assets, and other add-ons.

Has anyone seen this problem before? Any ideas what's going on? Thanks.

UPDATE

I tried deleting one of the page entries and recreating it. The new page has the same error.

I have put in a support ticket with my web host to see if they can review the server logs to find any clues.

1

It might be PHP memory. Try the following in your .htaccess file:

php_value memory_limit 128M

Updated: If this definitely improves some of them, you might need to keep bumping it up. Try 256M. You're throwing a solution at the problem to see if it fixes it. If so, it's a performance issue in those templates. You can try turning on the Template Debugger or Output Profiler to see what you can find as well, on the pages that will load.

| improve this answer | |
  • Does it matter where I put it in the .htaccess file? I added it at the end (not much in there anyway -- just some code to unsuccessfully strip index.php). It is a little better -- some of the pages will load, but if you reload them they may give the error. One page still consistently gives the error. – Amy Witty Feb 12 '13 at 21:16
  • Updated answer to address your comments. It shouldn't matter where in the .htaccess file you drop the code. – Mark J. Reeves Feb 12 '13 at 21:21
  • What should I be looking for in the Output Profiler? Memory usage? Number of queries? – Amy Witty Feb 12 '13 at 21:32
  • Adding this to .htaccess will only work if your running PHP as an Apache module. If you're running as CGI/FastCGI then you'll need to add it to php.ini (Also take a look at your Apache error_log to confirm it's a memory issue - it most likely is though.) – John Moylan Feb 12 '13 at 21:41
  • Memory usage - Yes. You can also try stripping down the template and adding to it bit by bit til you isolate the culprit. – Mark J. Reeves Feb 12 '13 at 21:46
0

Okay, at long last, my site appears to be working correctly. I corresponded with our web host, and they told me that I did not in fact have to include the "/~user" on the URL's for the site. I removed that and my previously broken pages are now loading correctly.

In other words, I was using a base URL of the form: http://numericIP/~user/ (as specified in the welcome email for the hosting account) but should have been using http://numericIP/ instead.

Thank you, everyone, for your efforts to help!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.