0

Using Assets 2.0.5 on EE2.5.5

When I remove index.php using Ellislab's official method Assets simply stops working. It's hard to explain without screenshots, but on existing entries all thumbs are gone and when you click add or remove file in an entry form you simply get a blank screen. More specifically what especially seems to trigger it, is leaving "Name of your site's index page" blank, the htaccess file doesn't seem to be the issue. More specific if I make Name of your site's index page blank, the behaviour happens, if I put index.php back it's working fine, even with the htaccess file.

Any suggestions?

1
  • What does your browser error console show? Also check the Chrome/Firebug network tab for any 404 or 500 errors. You can upload screenshots here if it will help us understand the problem better. Feb 15 '13 at 0:37
4

I've had a similar issue, which in the end had to do with me not being consistent with the usage of www. Is the behaviour the same when you use www or not? You could also add

$config['assets_site_url'] = '/index.php';

To the config file of EE, maybe that helps?

3
  • I was just going to respond to try that; just had a support ticket that required it. Erwin - please do give noregt's suggestion a shot. :) Thank you both!
    – Lisa
    Feb 15 '13 at 16:08
  • This indeed solved it right away. Thank you noregt & Lisa! Feb 17 '13 at 15:35
  • This just saved my life.
    – portnull
    Aug 5 '15 at 10:39
0

Do you have this part in the htaccess?

# Redirect index.php Requests
# Turn this off until index.php is removed from ExpEng Control Panel.
# -------------------------------------------------------------------
RewriteCond %{THE_REQUEST} ^GET.*index\.php [NC]
RewriteCond %{THE_REQUEST} !/system/.*
RewriteRule (.*?)index\.php/*(.*) /$1$2 [R=301,L]

There is likely something in the Assets (I've no experience with it) code that is using an URL to run a query, or something like that, and the rewrites are messing with it.

Also, you might try setting "Strict URLs" in the settings where you set the 404 page.

  • Bob

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.