2

I've set up my templates to add in-place comment editing and deletion. It's working great, and should be a useful feature.

However: Now that I'm ready to roll it out I'm attempting to test it with non-Super Admin users… and they can't see the Edit and Delete buttons.

Here's the code in question:

{if can_moderate_comment}
<a href="#" class="edit-link">Edit</a>
<a href="#" class="mod-link">Delete</a>
{/if}

(I've also tried if editable.)

The editing time limit is 0 (I tried setting it to something other than 0 without results).

It's obviously a permissions thing. but I can't find any combination of Member Group permissions that lets a Member see the Edit/Delete buttons on their own posts, but not on every other comment as well. I think I've tried just about every combination you can make in the Comment Administration section.

3

I'm pretty sure the "set to 0 for no limit" instruction is BS. I've had success using {if editable} and setting an arbitrarily high number like 9999999.

1
  • 1
    Aha. There seem to be two bugs here, actually: 1. The "0" setting was BS; 2. It took a couple tries for a new setting to stick. – Tim Feb 16 '13 at 1:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.