1

I am stuck again using IIS7 on a windows server. Trying to replicate the production environment for some testing on a Win7 box using IIS7 and host file to point o the sites.

I have tried using various methods to get a multi-server environment setup, but all have failed. This client in particular wants a development, staging, and production environment. I was looking at using Erik's setup for FocusLab (Thanks Erik!), but for this one in particular, I am trying to implement the one here.

Even trying to clean up my config file seems to break the site though. I can see the site index page, but the CP is jacked. (See screen)

enter image description here

Here is the code I have tried:

<?php //if ( ! defined('BASEPATH')) exit('No direct script access allowed');

/* ExpressionEngine Configuration
-------------------------------------------------------------------*/
$config['app_version'] = "255";
$config['license_number'] = "MY LICENSE";
$config['debug'] = "1";
$config['install_lock'] = "";
$config['system_folder'] = "MY SYS";
$config['is_system_on'] = "y";
$config['allow_extensions'] = "y";
$config['site_url'] = "http://".$_SERVER['HTTP_HOST'];
$config['server_path'] = FCPATH;
$config['cp_url'] = $config['site_url'] . '/MY SYS/';
$config['theme_folder_url'] = $config['site_url']."/themes/";
$config['theme_folder_path'] = $config['server_path']."/themes/";
$config['save_tmpl_files'] = "y";
$config['tmpl_file_basepath'] = $config['server_path']."/templates/";

/* CodeIgniter Configuration
-------------------------------------------------------------------*/
$config['base_url'] = $config['site_url'];
$config['uri_protocol'] = 'AUTO';
$config['language'] = 'english';
$config['charset'] = 'UTF-8';
$config['subclass_prefix'] = 'EE_';
$config['permitted_uri_chars'] = 'a-z 0-9~%.:_\\-';
$config['enable_query_strings'] = FALSE;
$config['directory_trigger'] = 'D';
$config['controller_trigger'] = 'C';
$config['function_trigger'] = 'M';
$config['log_threshold'] = 0;
$config['log_path'] = '';
$config['log_date_format'] = 'Y-m-d H:i:s';
$config['time_reference'] = 'local';

/* End of file config.php */
/* Location: ./system/expressionengine/config/config.php */

Even if I turn off the direct script access denial, I can't display FCPATH. It seems to be an issue with IIS7 and FCPATH.

Any ideas how I can get this going?

* EDIT * I started looking at the paths that EE was trying to use and they are showing this: http://bootstrap.com/%3C?=$cp_avatar_path%20?%20$cp_avatar_path%20:%20$cp_theme_url.'images/site_logo.gif'?%3E

%3C is for the '<' character, %20 is space, and %3E is the '>' character.

This is obviously an image being attempted to be rendered.

Is there a reason for the encoded characters showing instead?

2

Why not use http://eeinsider.com/articles/multi-server-setup-for-ee-2/ as a basis and work from there?

| improve this answer | |
  • taking a look now... – W3bGuy Feb 15 '13 at 20:42
  • Thanks for the nudge SG. It ended up being a stupidly overlooked setting of not having short tags on. Crawling through the settings, I caught it when I was comparing the files though. Thanks. – W3bGuy Feb 15 '13 at 21:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.