I’m working on a MSM setup and I’ve got the index template going, but the system won’t show the subtemplates.

To explain the basis situation:

I setup the Multiple Site Manager for two domains. One is the first domain, which worked as expected, The second one is in a subfolder with it's own DNS domain name.

Basically I setup the sites with the index.php and admin php files placed in their folders as instructed in the docs, but for some reason links didn't work in the second domain. Every link just shows the default template.

I've set the index.php file for the second domain as follows:

config settings:

$assign_to_config[‘site_name’] = ‘f...._nl’;
$assign_to_config[‘cp_url’] = ‘........nl/admin.php’;
$assign_to_config[‘site_url’] = ‘.......nl’;


  • Can you clarify some of your language here? Do you mean that it won't load template groups or templates, but only the index* template from your default template group? Is this happening for all sites? Commented Feb 19, 2013 at 18:50
  • Thanks Derek for keeping an eye on this. It was a quite popular live site, so I was a bit in a hurry and decided to post it at the support desk from EE too. Hopefully the answer will be helpful for others
    – noregt
    Commented Feb 19, 2013 at 20:56

1 Answer 1


Meanwhile I've got it sorted out with the help of the EE team.

The odd behaviour was that the main site worked, and the secondary domain too, but links didn't work in the second domain, every url parsed the default index template. Setting

$config['uri_protocol'] = "PATH_INFO";

In the config file was the solution to making it work normally. (although the behaviour confused Robin from EE too).

  • Glad it worked. If possible, could you please elaborate on what your exat setup was (MSM and multi-domains if I understood). This looks like a tricky one, whatever you can do to help others down the line would be much appreciated. Commented Feb 20, 2013 at 6:35
  • I've edited the question and the answer, hopefully it makes more sense now.
    – noregt
    Commented Feb 20, 2013 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.