Doing some testing on a local version of a website, trying to implement an Assets upload field in a Matrix column. When in the publish form and I click the "Add Files" button the modal pops up but it is blank. I do get a console error in Chrome dev tools...


XMLHttpRequest cannot load http://condley-intranet.dev/. Origin http://condley-banking.dev is not allowed by Access-Control-Allow-Origin.

Uncaught TypeError: Cannot set property 'innerHTML' of undefined assets.min.js:8

qq.FileUploader assets.min.js:8

Assets.FileManager.Garnish.Base.extend.init assets.min.js:8

Garnish.Base.a.extend.constructor garnish-0.1.min.js:18

h.constructor garnish-0.1.min.js:14

h.constructor garnish-0.1.min.js:14

(anonymous function) assets.min.js:8

d jquery.js:39

b.extend.each jquery.js:37

b.fn.b.each jquery.js:30

c.ajax.complete jquery.js:161

p jquery.js:43

l.fireWith jquery.js:44

d jquery.js:167

b jquery.js:178


I'm using the Assets/Matrix combo on a MSM site. The "main" site is "condley-banking.dev". The MSM site is "condley-intranet.dev". I'm logged in to the CP through the "condley-banking.dev" site and then selected the MSM site from the CP dropdown. I thought this info might help after reading the error, but it's al lover my head. Thanks for any information!

  • If I login to the Control Panel of the MSM site url instead of the "main" url I get a little farther, but it's still not working completely. I can see the Upload Files button, the search bar, and the display option buttons. But when I try and upload it acts like it uploads, but doesn't display anything in the modal. Feb 22, 2013 at 17:19
  • Do you see any errors in the dev console when loading the Modal? Also, can you add your version information for Assets, Matrix, and EE? Thank you!
    – Lisa
    Feb 22, 2013 at 17:31
  • No errors this time :/ Assets v2.0.5, Matrix v.2.5.3, EE v.2.5.5 Feb 22, 2013 at 17:36
  • I've also triple-checked to make sure the themes folder was uploaded all the way Feb 22, 2013 at 17:37
  • 1
    Mike, I should have had you look at that first thing. Thank you for letting me know. I'd recommend posting it as the answer and accepting that as the official answer.
    – Lisa
    Feb 22, 2013 at 21:27

2 Answers 2


Your JS forms look like they're attempting a cross-domain communication:

HTMLHttpRequest cannot load http://condley-intranet.dev/. Origin http://condley-banking.dev is not allowed by Access-Control-Allow-Origin.

Are you able to locate where you're crossing domains and make them consistent? I'd start with your General Config and/or /system/expressionengine/config/

  • Lisa, I just made a comment above with some more info... Feb 22, 2013 at 17:20
  • Lisa, this just saved my butt. Was missing www and once added all started working again.
    – CreateSean
    Jul 12, 2013 at 18:57

I had not "Updated Indexes" in the plugin CP. Afte that things worked fine.

  • This worked for me too.
    – kmgdev
    Dec 11, 2013 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.