The Problem: When trying to login via the front-end as a member, the error "you are not authorised to perform this action" appears. The url for the error page is that of another MSM site. If I go to original site, I am logged in as that user.

My Setup: - EE version 5.5.2 - Multisite Manager

  • Require IP Address : NO
  • User Agent for Login : NO
  • Secure Forms: NO
  • Deny Duplicate Data: NO
  • Sessions are using cookies only

Blacklist module: not installed Securitee - Installed but with minimal settings active.

I have tried the following to no avail:

  1. Logging in via default EE member templates and via template created with Freemember.
  2. Removed "Freemember" and "User"
  3. Tried from different device and different IP Address
  4. Tried disabling all extensions using config.php
  5. Tried removing my htaccess
  6. Clearing site cache, and browser cache
  7. Creating new members,
  8. Signing onto front end as superadmin

I noticed in my config.php I have a token for $config['XID'] = Should this be there? I have read that this can cause such issues.

Please help - Im not sure what to try next.

I went onto Site3 Front end and I created a user in the Members group. When I login from the front end of either Site1 or Site2, it all works okay, (even thought I signed up as a member to Site3.) But it wont let me login nicely to Site3! The url is redirecting to Site1 first saying im not authorised.

1 Answer 1


You can sift through the database and check the member group permissions.

*exp_member_groups* will store general access settings per site. *exp_channel_member_groups* stores a relationship to each channel and member group.

My guess is you'll find something goofed up in the member_groups table.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.