0

I've tried upgrading EE from 2.5.2 to 2.5.5. The upgrade apparently went through OK, but when I login to the CP - none of the menu items are clickable and also the rounded borders on the menu items don't display.

I'm also getting an error when CP tries to load the following as a script;

admin.php?S=0&D=cp&C=javascript&M=load&file=css&theme=default&v=1356028154

When I check the Sources tab in Chrome Developer tool, I see the following;

<div style="border:1px solid #990000;padding-left:20px;margin:0 0 10px 0;">

<h4>A PHP Error was encountered</h4>

<p>Severity: Notice</p>
<p>Message:  unserialize(): Error at offset 0 of 88 bytes</p>
<p>Filename: libraries/Extensions.php</p>
<p>Line Number: 229</p>

</div>(function($, doc) {var adv_css = {".button a,\n.cp_button a,\n#search form,\ndiv.contentMenu,\n#mainContent .formArea,\n#navigationTabs .first_level:not(.addTab)":{"border-radius":"10px"},"#navigationTabs .addTab":{"border-radius":"none"},"#accessoryTabs li,\n.heading":{"overflow":"hidden","border-top-right-radius":"10px","border-top-left-radius":"10px"},".tableFooter,\ndiv.pageContents,\n#mainContent #publishForm":{"border-bottom-right-radius":"10px","border-bottom-left-radius":"10px"},".newTemplate":{"border-radius":"5px"},"#write_mode_writer":{"border-radius":"15px"},".js_hide":{"display":"none"}}, selector, compat_el = doc.createElement("ee_compat"),supported = false,inline_css = [],use = ["", "", "$1$3"],prefixes = " webkit o ms moz Moz".split(" "),corners = " -top-right -top-left -bottom-right -bottom-left".split(" "),regex = /^-(.)(.*?)-(.)(.*)/,css_radii = {};$.each(prefixes, function(i) {var name = i ? this+"BorderRadius" : "borderRadius";if (compat_el.style[name] !== undefined) {if (i == 0) {use = ["border", "-radius", ""];}else if (i < 3) {use = ["-"+this+"-border", "-radius", ""];}else {use = ["-moz-border-radius", "", "-$1$2$3$4"];}supported = true;return false;}});$.each(corners, function(i, v) {if (use[2]) {v = v.replace(regex, use[2]);}css_radii["border"+this+"-radius"] = use[0]+v+use[1];});function process_css(key, value) {if (key.indexOf("@") == -1) {var apply_radius = "",sep = (supported) ? ":" : " ",jQel;for (radius in css_radii) {if (value[radius]) {apply_radius += css_radii[radius]+sep+value[radius]+";";delete(value[radius]);}}if (supported) {inline_css.push(key+"{"+apply_radius+"}");}else {jQel = $(key).css(value);if (apply_radius) {}}}else if (key.indexOf("@"+EE.router_class) != -1) {$.each(value, process_css);}}if (supported) {$.each(adv_css, process_css);var head = doc.getElementsByTagName("head")[0],ss_txt = doc.createTextNode(inline_css.join("\n")),ss_el = doc.createElement("style");ss_el.setAttribute("type", "text/css");ss_el.appendChild(ss_txt);head.appendChild(ss_el);}else {$(doc).ready(function() {$.each(adv_css, process_css);});}})(jQuery, this.document)

Wondered if anyone else had this issue? :/

4
  • Did you upload the 2.5.5 javascript and cp_themes folders (both found in /themes)? Feb 25 '13 at 13:18
  • Hey Derek, yes those folders are in the /themes folder. I think the issue might be the admin.php like that shoes '&amp;' instead of '&' ? Feb 25 '13 at 13:48
  • THose folders are there, but are they from the 2.5.5 download? Did you replace them during the upgrade? Feb 25 '13 at 14:37
  • Yep, they're from the 2.5.5 download and replaced during upgrade. I can see all of the jQuery UI scripts in /themes/javascript/compressed/jquery/ui/ :/ Feb 25 '13 at 14:46
0

An unserialise error with extensions probably means extension settings. Try disabling each extension one by one (backup first)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.