1

FreeForm 3.1.4 ExpressionEngine 2.5.5 Build 20121220

Hi There,

When submitting my form, it takes you to the root domain (www.domain.com) and shows a white/blank page. It is not adding the entry to the database either or at least it isn’t showing in the Entries Tab.

I have tried with no .htaccess file Communicate tab works.

It happens on another form on the same site as well.

Any ideas? See my template code below:

{exp:freeform:form
           collection="Contact Form"
           required="name|email|question"
           return="/contact/thank-you"
           notify="mark@domain.com" 
           template="contact"
        }

        <p class="form-element">
            <label>Name: </label>
            <input type="text" name="name" class="txtbox" />
        </p>

        <p class="form-element">
            <label>Email: </label>
            <input type="text" name="email" class="txtbox" />
        </p>

        <p class="form-element">
            <label>How did you hear about us?</label>
            <select name="how_hear" />
                <option value="Please Select">Please Select</option>
                <option value="Word of mouth">Word of mouth</option>
                <option value="Search engine">Search engine</option>
                <option value="Online school listing">Online school listing</option>
                <option value="Facebook">Facebook</option>
                <option value="Twitter">Twitter</option>
                <option value="Press">Press</option>
                <option value="Banners">Banners</option>
                <option value="School minibus">School minibus</option>
                <option value="Toddler class">Toddler class</option>
                <option value="Other">Other</option>
            </select> 
        </p>

        <p class="form-element">
            <label>If other, please specify: </label>
            <input type="text" name="other" class="txtbox" />
        </p>

        <p class="form-element">
            <label>Questions or Comments:</label>
            <textarea name="question"></textarea>
        </p>

        <p><input type="submit" id="submit" name="submit" value="Submit" /></p>

        {/exp:freeform:form} 

Many thanks

  • Have you enabled php error reporting to screen? I would guess that there is a mysql/php error but your error reporting is turned down too low. – JohnWBaxter Feb 27 '13 at 14:41
2

This was resolved in the Solspace forums here: http://www.solspace.com/forums/viewthread/15814/

Basically, once debugging was enabled the blank page displays this message:

A Database Error Occurred

Error Number: 1054 Unknown column ‘ip_address’ in ‘where clause’

SELECT COUNT(*) AS count FROM exp_security_hashes WHERE hash=‘181350a948fdb9c1b7e2c0646bebf75b7c7c5ea1’ AND ip_address = ‘86.146.35.53’ AND date > UNIX_TIMESTAMP()-7200

Filename: third_party/freeform/mod.freeform.php

Line Number: 1106

This is an issue with EE 2.5.4+ removing the ip_address column from the exp_security_hashes table.

Upgrading to Freeform 3.1.5 or Freeform 4, which have this fixed, should resolve the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.