1

I have confused myself slightly setting up the return path for my safecracker login form for the following site [Click here for link][1]

if you scroll down to the roster section click mel debarge, in the the pop up you will notice a download section, when you click on the press kit button you are redirected to the login page.

When user enter the correct login detail they are able to access a PDF/JPEG which i have uploaded in the Matrix i have set up. The parameters for the matrix are the following {press_material}{press_pdf}{press_material}

In the entry properties for my login form i have the following:

{exp:safecracker
channel="roster"
    dynamic_title="[member_first_name] [member_last_name]"
    include_jquery="no"
    group_id="5"
    loggin_member="yes"
    error_handling="inline"
    return="{path='{press_material}{press_pdf}{/press_material}/{url_title}'}"

In aim to redirect registered users to the file uploaded in the matrix, However i don't seem to be having any joy. Does anyone know how i can resolve this issue??

do i need to use the embed proporties in order for this to work?

[1]:

  • Does this work with a hardcoded URL based on what you are trying to accomplish with the tags? – Anna_MediaGirl Mar 3 '13 at 20:06
  • @Anna_MediaGirl i'm trying to work out a url... – NewBoy Mar 4 '13 at 2:26
  • I understand that. I'm asking if you've tried hard coding a URL that should work as a test. – Anna_MediaGirl Mar 4 '13 at 5:58
  • yes. Hard coding the URL, works fine – NewBoy Mar 4 '13 at 15:47
  • Okay. Sounds like something isn't parsing correctly then. Try overriding the return="" parameter inside the safecracker tag using: <input type="hidden" value="{path='{press_material}{press_pdf}{/press_material}/{url_title}" name="return"> OR <input type="hidden" value="/{press_material}{press_pdf}{/press_material}/{url_title}" name="return"> – Anna_MediaGirl Mar 4 '13 at 16:35
1

The fix for this was twofold:

  1. Needed to add register_member="yes" to the Safecracker Registration tag

  2. {url_title} wasn't being parsed as coded. Changing the tag to {segment_3} got the return path working correctly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.