2

am trying to set up a kind of project management type site and am using matrix and assets. The idea being that over the course of the project multiple galleries could be uploaded, so in the custom field have got Matrix set up with a date column and an asset column, have entered in one sample gallery, but it's only outputting 1 image - the images are there in the entry and in assets, but am stuck how to get it to output all of the images, my code is:

{images}
    {date format="%d %F %Y"} - {images}
{/images}

Any ideas what I've done wrong

Cheers Jonny

1

Jonathan,

What is {images}?

If we can back up and you can add a bit more context to your post, that would help. Version numbers for Assets,Matrix, and EE would be a great start. Also, a screenshot of your Matrix field would be great! Essentially you need something like this, though:

{exp:channel:entries channel="your_channel"}
<h1>{title}</h1>

    {your_matrix_field}
            {your_assets_column}
                        {filename}<br />
           {/your_assets_column}
    {/your_matrix_field}
{/exp:channel:entries}
| improve this answer | |
  • AH, cool cheers - it was the asset column, I was only using the matrix field not breking it down more – Jonathan Rapp Mar 5 '13 at 8:11
  • Awesome! If this works for you, please do accept it as the answer? :) – Lisa Mar 5 '13 at 19:26
0

Sounds like your tag names aren't matching your settings correctly.

{images}
    {date format="%d %F %Y"} - {images}
{/images}

In your example, the first {images} should be the field name and the second {images} should be your Matrix column name. Is {images} the name of your Matrix column or is it something else?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.