2

I am using structure, and therefore, sometimes I have more than the standard 2 segements (template_group/template).

the error page get's triggered whenever the first or the second segment is incorrect, but it's not triggered as soon as there is a third segment.

I've tried this on several structure sites and seems to be consistent.

I also used libraree on these sites.

are you experiencing the same thing?
is there any way to overcome this?

cheers
stefan

9
  • 2
    Are you using the Freebie addon?
    – Anna_MediaGirl
    Mar 5 '13 at 16:25
  • yes... but I have tried it with or without it... did you try on one of your installs with structure?
    – outline4
    Mar 6 '13 at 18:25
  • I didn't, it's just another piece of the puzzle. Have you tried without your htaccess file?
    – Anna_MediaGirl
    Mar 6 '13 at 18:33
  • yup... it's the same...
    – outline4
    Mar 7 '13 at 11:11
  • what's your url structure? stupid question but does the url structure exist within the Structure site tree? Mar 12 '13 at 13:41
1

If you have Strict URLs turned off, then an incorrect third segment is most likely parsing the index.html template of the default template group. Unless that template has a way to verify the URL against an entry, it will parse normally everything that it can.

So, I'd work in a 404 solution for your default template. Two different options could be:

{if segment_3}{embed="templategroup/404"}{/if}

OR

{if segment_3}{redirect="/"}{/if}
6
  • hi - thanks for your answer... but that won't work, since with structure you CAN have a third segment! EE just can't detect whether it's a correct one or not.
    – outline4
    Nov 5 '13 at 12:02
  • Did you test? What were the results? Nov 5 '13 at 12:05
  • hm, no - I didn't test it... and when I come to think of it, your solution could work since EE will only recognize a third segment when the {triggers:segement_3} is not present... ha... that might really work. did you test it on your end?
    – outline4
    Nov 5 '13 at 12:09
  • I don't have the problem. :) Nov 5 '13 at 12:10
  • ok - i'll try it and report back! thanks already!
    – outline4
    Nov 5 '13 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.